Mythruna
September 20, 2020, 09:04:44 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Welcome to the new forums. See "Announcements" for a note for new users.
 
   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: [crash] ConnectorException: Connector closed.  (Read 8596 times)
PrivateAlpha
Newbie
*
Posts: 14


View Profile
« on: April 20, 2013, 03:37:30 PM »

Code:
Uncaught exception from thread:Thread[com.jme3.network.kernel.tcp.SocketConnector@60c0cdfe,5,main]
com.jme3.network.kernel.ConnectorException: Connector closed.
at com.jme3.network.base.ConnectorAdapter.run(ConnectorAdapter.java:162)

I don't know if this has been reported, but here it is anyway


Full file: (We need spoilers)
Code:
Uncaught exception from thread:Thread[com.jme3.network.kernel.tcp.SocketConnector@60c0cdfe,5,main]
com.jme3.network.kernel.ConnectorException: Connector closed.
at com.jme3.network.base.ConnectorAdapter.run(ConnectorAdapter.java:162)

Build version:20120627

Gathering app info from OpenGL thread...
Memory usage:
Working memory: 92% (453101576/489160704)  VM Max: 92% (453101576/489160704)

Rendering caps:
    FrameBuffer
    FrameBufferMRT
    FrameBufferMultisample
    TextureMultisample
    OpenGL20
    OpenGL21
    OpenGL30
    OpenGL31
    OpenGL32
    ARBprogram
    GLSL100
    GLSL110
    GLSL120
    GLSL130
    GLSL140
    GLSL150
    VertexTextureFetch
    TextureArray
    TextureBuffer
    FloatTexture
    FloatColorBuffer
    FloatDepthBuffer
    PackedFloatTexture
    SharedExponentTexture
    PackedFloatColorBuffer
    TextureCompressionLATC
    NonPowerOfTwoTextures
    MeshInstancing
    VertexBufferArray

Statistics:
  Vertices = 1165177
  Triangles = 600426
  Uniforms = 12603
  Objects = 1426
  Shaders (S) = 68
  Shaders (F) = 25
  Shaders (M) = 35
  Textures (S) = 307
  Textures (F) = 84
  Textures (M) = 119
  FrameBuffers (S) = 6
  FrameBuffers (F) = 5
  FrameBuffers (M) = 6
Application settings:
UseInput = true
AudioRenderer = LWJGL
Height = 900
Renderer = LWJGL-OpenGL2
BitsPerPixel = 16
Fullscreen = true
StencilBits = 0
DepthBits = 24
VSync = true
Frequency = 60
Width = 1440
Samples = 0
DisableJoysticks = true
FrameRate = -1

Display adapter information:
Adapter:nvd3dumx,nvwgf2umx,nvwgf2umx
Driver Version:9.18.13.1106
Vendor:NVIDIA Corporation
Version:4.3.0
Renderer:GeForce GTX 460/PCIe/SSE2
GLSL Ver:4.30 NVIDIA via Cg compiler
Logged
Sean
Donators
Hero Member
***
Posts: 598



View Profile
« Reply #1 on: April 20, 2013, 04:06:22 PM »

Exactly what were you doing when you got this error? It looks to me you failed to connect to the server, but I could be wrong.
Logged

"People willing to trade their freedom for temporary security deserve neither and will lose both." - Benjamin Franklin
PrivateAlpha
Newbie
*
Posts: 14


View Profile
« Reply #2 on: April 20, 2013, 05:40:52 PM »

Nah, I can connect to the server just fine, it happens randomly, boot up the game again and it is fine.
Logged
pspeed
Administrator
Hero Member
*****
Posts: 5578



View Profile
« Reply #3 on: April 20, 2013, 07:55:50 PM »

The network connection glitched for some reason.  The game doesn't have a facility for reconnecting automatically so it can only die.
Logged
Michael Musgrove
Donators
Hero Member
***
Posts: 2164



View Profile WWW
« Reply #4 on: May 16, 2013, 09:20:17 PM »

I was working on my server, and this happened when I placed an object..
Logged

pspeed
Administrator
Hero Member
*****
Posts: 5578



View Profile
« Reply #5 on: May 16, 2013, 09:33:32 PM »

I was working on my server, and this happened when I placed an object..

Then there was an error on the server or something... or your network is totally messed up.
Logged
Michael Musgrove
Donators
Hero Member
***
Posts: 2164



View Profile WWW
« Reply #6 on: May 16, 2013, 09:38:19 PM »

I was working on my server, and this happened when I placed an object..

Then there was an error on the server or something... or your network is totally messed up.

Yeah, my modem has been acting up a little bit, like not but 2 days ago it completely shut off randomly.. ( only thing that was on was the 'power' ). We just got that but half a year ago :/ and soon we are getting OG&E smart hours.. So I don't be able to release my server for Mythruna until we get rid of it Tongue
Logged

Rayblon
Donators
Hero Member
***
Posts: 1847


One day I'll be a species in Mythruna...


View Profile
« Reply #7 on: July 12, 2014, 10:19:13 AM »

I've got a huge pile of error logs, and this is the only thing in them ._.
Logged

Tamarie
Jr. Member
**
Posts: 52


View Profile
« Reply #8 on: July 14, 2014, 01:01:58 AM »

Is my latest problem totally different? This time restarting my modem does no good. I've tried adding Mythruna to firewall exceptions, but I'm probably not calling it the right thing. "Mythruna.game-host"?

Uncaught exception from thread:Thread[LWJGL Renderer Thread,5,main]
java.lang.IllegalStateException: Client is not started.
   at com.jme3.network.base.DefaultClient.checkRunning(DefaultClient.java:119)
   at com.jme3.network.base.DefaultClient.close(DefaultClient.java:252)
   at mythruna.client.net.LoginClient.close(LoginClient.java:184)
   at mythruna.client.LoginState.returnToMain(LoginState.java:315)
   at mythruna.client.LoginState$1.perform(LoginState.java:383)
   at de.lessvoid.nifty.screen.Screen$ElementWithEndNotify.remove(Screen.java:802)
   at de.lessvoid.nifty.screen.Screen.processAddAndRemoveLayerElements(Screen.java:569)
   at de.lessvoid.nifty.Nifty.removeLayerElements(Nifty.java:333)
   at de.lessvoid.nifty.Nifty.handleDynamicElements(Nifty.java:314)
   at de.lessvoid.nifty.Nifty.update(Nifty.java:253)
   at com.jme3.niftygui.InputSystemJme.endInput(InputSystemJme.java:92)
   at com.jme3.input.InputManager.processQueue(InputManager.java:787)
   at com.jme3.input.InputManager.update(InputManager.java:851)
   at com.jme3.app.Application.update(Application.java:605)
   at com.jme3.app.SimpleApplication.update(SimpleApplication.java:233)
   at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:149)
   at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:182)
   at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:223)
   at java.lang.Thread.run(Unknown Source)

Build version:20120627

Memory usage:
Working memory: 60% (12048512/19857408)  VM Max: 2% (12048512/518979584)

Rendering caps:
    FrameBuffer
    FrameBufferMRT
    FrameBufferMultisample
    TextureMultisample
    OpenGL20
    OpenGL21
    OpenGL30
    OpenGL31
    OpenGL32
    ARBprogram
    GLSL100
    GLSL110
    GLSL120
    GLSL130
    GLSL140
    GLSL150
    VertexTextureFetch
    TextureArray
    TextureBuffer
    FloatTexture
    FloatColorBuffer
    FloatDepthBuffer
    PackedFloatTexture
    SharedExponentTexture
    PackedFloatColorBuffer
    TextureCompressionLATC
    NonPowerOfTwoTextures
    MeshInstancing
    VertexBufferArray

Statistics:
  Vertices = 888
  Triangles = 444
  Uniforms = 216
  Objects = 111
  Shaders (S) = 21
  Shaders (F) = 6
  Shaders (M) = 6
  Textures (S) = 25
  Textures (F) = 12
  Textures (M) = 14
  FrameBuffers (S) = 5
  FrameBuffers (F) = 4
  FrameBuffers (M) = 4
Application settings:
UseInput = true
AudioRenderer = LWJGL
Height = 1024
Renderer = LWJGL-OpenGL2
BitsPerPixel = 32
Fullscreen = true
StencilBits = 0
DepthBits = 24
VSync = false
Frequency = 60
Width = 1280
Samples = 0
DisableJoysticks = true
FrameRate = -1

Display adapter information:
Adapter:nvd3dumx,nvwgf2umx,nvwgf2umx
Driver Version:null
Vendor:NVIDIA Corporation
Version:4.3.0
Renderer:GeForce GTX 580/PCIe/SSE2
GLSL Ver:4.30 NVIDIA via Cg compiler
Logged
Michael Musgrove
Donators
Hero Member
***
Posts: 2164



View Profile WWW
« Reply #9 on: July 14, 2014, 07:05:40 AM »

Code:
java.lang.IllegalStateException: Client is not started.
Lolwut? Try starting your client?
Logged

pspeed
Administrator
Hero Member
*****
Posts: 5578



View Profile
« Reply #10 on: July 14, 2014, 07:26:43 AM »

Code:
java.lang.IllegalStateException: Client is not started.
Lolwut? Try starting your client?

That's not the kind of thing that you can 'start'... it's a code problem.  Probably the server needs to be reset.

I just now reset it... but I had to wait for someone to log off first so I'm not entirely sure the problem is on my end this time.
Logged
Michael Musgrove
Donators
Hero Member
***
Posts: 2164



View Profile WWW
« Reply #11 on: July 14, 2014, 08:03:11 AM »

Code:
java.lang.IllegalStateException: Client is not started.
Lolwut? Try starting your client?

That's not the kind of thing that you can 'start'... it's a code problem.  Probably the server needs to be reset.

I just now reset it... but I had to wait for someone to log off first so I'm not entirely sure the problem is on my end this time.
Heh, it was just a joke. Tongue

I'm able to connect, so it's not your end, or at least if it was, it's not anymore.
Logged

Tamarie
Jr. Member
**
Posts: 52


View Profile
« Reply #12 on: July 14, 2014, 03:16:47 PM »

My computer crashed during the night, so I don't know for certain that my problem was on your end, but I'm baaaack. Yay and thanks.
Logged
Rayblon
Donators
Hero Member
***
Posts: 1847


One day I'll be a species in Mythruna...


View Profile
« Reply #13 on: July 14, 2014, 06:07:12 PM »

There's a player who's ID number is 54, name is Null, and IP address is unknown... That 'user' is almost always on the server... Who, or what, is that user?
Logged

Michael Musgrove
Donators
Hero Member
***
Posts: 2164



View Profile WWW
« Reply #14 on: July 14, 2014, 08:00:29 PM »

There's a player who's ID number is 54, name is Null, and IP address is unknown... That 'user' is almost always on the server... Who, or what, is that user?
It's a null (non-existent) player. I believe these are created from when a player crashes. I crashed not too long ago on it, it just went all wack and froze on me.. Normally, they'll go away by themselves or a server reset will fix it.
Logged

Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!