Mythruna
January 24, 2020, 11:24:40 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Welcome to the new forums. See "Announcements" for a note for new users.
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Will not open  (Read 6183 times)
exscentric
Newbie
*
Posts: 6


View Profile
« on: September 13, 2015, 02:00:12 PM »

Have been using Mythruna on my pc for months - today the first screen opens, I click okay and nothing happens.  Had a java update yesterday, do not know if that is the problem.

error-1442176614397.log is new, contents below:

Uncaught exception from thread:Thread[LWJGL Renderer Thread,5,main]
org.lwjgl.LWJGLException: Pixel format not accelerated
   at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
   at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(WindowsPeerInfo.java:52)
   at org.lwjgl.opengl.WindowsDisplay.createWindow(WindowsDisplay.java:210)
   at org.lwjgl.opengl.Display.createWindow(Display.java:306)
   at org.lwjgl.opengl.Display.create(Display.java:873)
   at org.lwjgl.opengl.Display.create(Display.java:782)
   at com.jme3.system.lwjgl.LwjglDisplay.createContext(LwjglDisplay.java:137)
   at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:113)
   at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:205)
   at java.lang.Thread.run(Unknown Source)
Application was not initialized.

Also, after deleting blocks for a long time the video goes funny, looks like you are seeing underlying structure instead of the blocks.  Wait a few seconds and blocks reappear but if you continue deleting the same thing happens.  Continue the cycle and it locks up - when you go to the exit screen is blank - if you move cursor and listen to the drum beat you can close it.
Logged
pspeed
Administrator
Hero Member
*****
Posts: 5573



View Profile
« Reply #1 on: September 13, 2015, 02:28:52 PM »

Sorry you are having trouble.  Seems more likely a problem with your display drivers.  If they were updated recently then perhaps they are exhibiting a new issue.  If you have an ATI/AMD card then that can be pretty common with driver updates and you may need to go back to a previous version.

As to the other, it sounds like the GPU is hanging perhaps... especially if everything else is still going.  Not sure what causes that.
Logged
exscentric
Newbie
*
Posts: 6


View Profile
« Reply #2 on: September 14, 2015, 05:46:42 AM »

Thanks much, will see what I can find.

Just for informational purposes:  Had played game several times since video drivers had been updated.  Reverted to Java 7 and all is well.  This is on an all in one computer with cheap graphics - I was surprised the game ran on it at all when first downloading the game.

Thanks for all your work!  I've spent too much time with the game but have enjoyed it greatly.

« Last Edit: September 14, 2015, 08:25:58 AM by exscentric » Logged
exscentric
Newbie
*
Posts: 6


View Profile
« Reply #3 on: September 21, 2015, 08:57:23 AM »

Just for information sake:  On the video problem I was searching through the forum and found a suggestion concerning another problem that seems to help my problem of all blocks disappearing.

The suggestion was to tap F12 three times.  I tried this before starting my game and if allowed me to play MUCH longer before the video problem appeared.  (Maybe 2 hours play before to 4-5 hours now.)  I also found that after the problem did arise that if I cycled through the F12 series twice the problem disappeared and I could continue to play.

Thought I'd post this in case others ran into the problem.

I found it very frustrating due to the fact that I am working a long way away from the start point of the game.
Logged
pspeed
Administrator
Hero Member
*****
Posts: 5573



View Profile
« Reply #4 on: September 22, 2015, 12:59:59 AM »

Well, that will reduce the clip so the game is taxing the memory much less.  I guess this is on single player?

As to fixing the issue when the problem occurs, if hitting F12 a bunch of time fixes it then it may just be because it forces a hard GC sometime because of all the churn.  (It's also possible something was hung and this kicks it in the butt but I don't think so.)

So when that happens, another thing you can try is pressing the 'x' key a few times as that will also force a GC directly. (It's what the key does.)

GC = "garbage collection"
Logged
exscentric
Newbie
*
Posts: 6


View Profile
« Reply #5 on: September 22, 2015, 12:20:14 PM »

Will give X a try next time.
Logged
exscentric
Newbie
*
Posts: 6


View Profile
« Reply #6 on: September 24, 2015, 05:55:13 AM »

Yes, the x key allows me to proceed when the video problem arises :-)  Thanks.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!